Supported Amazon Fire Tablets

Posted

Bookshelf 4 for Kindle Fire requires a Fire (4th Generation) or greater.  

How do I know what Kindle Fire Tablet I have

For Kindle Fire tablets manufactured in 2013 and later; Slide down the quick menu and tap Settings then tap Device Options.

In the Device Options Screen scroll to the bottom of the screen and locate Device Model.  This section will tell you what Generation of Kindle Fire you have.  Amazon labels their generations based on the year they released the device.

For instance, Amazon released the Fire (5th Generation) in 2015.  

VitalSource Supported Kindle Fire Tablets

Kindle Fire / Year Model Name Generation
Fire HD 6 (2014)  KFARWI  4th Generation
Fire HD 7 (2014)  KFASWI  4th Generation
Fire HDX 8.9 WAN (2014)  KFSAWA  4th Generation
Fire HDX 8.9 (2014)  KFSAWI  4th Generation
Fire HD 10 (2015)  KFTBWI  5th Generation
Fire HD 8 (2015)  KFMEWI  5th Generation 
Fire (2015)  KFFOWI  5th Generation 
Fire HD 8 (2016)  KFGIWI  6th Generation 
Fire 7 (2017)  KFAUWI  7th Generation 
Fire HD 10 (2017)  KFSUWI  7th Generation 
Fire HD 8 (2017)  KFDOWI  7th Generation 

 

Important: Bookshelf will not work with The Kindle Fire Phone or any of the Kindle Fire Sticks.
people found this useful.
Was this article helpful?
0 out of 0 found this helpful